U.S. Bank Now Supports Open Banking for Tiller Customers

Welcome, @johntraynor :wave:

I’m not seeing this line you’re referring to in the post above? Perhaps that’s in a different post/email?

Followed the instructions and still getting this…


This comes after I log into US Bank and authorize it to link to the US Bank Accounts. Have tried multiple times.

1 Like

Please reach out to our support team via the chat window in the lower right corner of the Console at https://my.tillerhq.com/ - we can’t troubleshoot these issues in the Tiller Community.

See the two circled items to confirm this is on the same page…

1 Like

But that aside, when I’ve tried to add U.S. Bank, I get this:

I’ve tried multiple times. Yodlee interface seems pretty buggy.

I get the same thing. Still doesn’t work. Hasn’t worked since mid January for me.

Thanks @johntraynor - we’ve got that text fixed on the blog.

We’re noticing some customers (but not all) are having issues with the open banking connection.

We’ve reached out to our data provider to understand what’s going wrong here.

For now we’re treating it as an outage.

We appreciate your patience.

1 Like

Just want to chime in that I am getting a partial connection to US Bank. The balances for the accounts download and appear on the Connected Accounts Summary, however there is a yellow alert icon next to the US Bank header and instead of displaying the last refresh date/time, it says “unknown refresh date”. And although the balances appear on this page, the transaction detail does not appear in the Transactions tab.

Thanks for letting us know. We’ll be sure to update the outage sheet once this widespread issue is resolved.

Same for me. Still waiting for it to work.

Noooooooooooooooooooooo! I have been waiting for US Bank to actually work for so long and to have it be fake news that it is working is so disheartening.

Hi @kim.dushinski and @Cowboy13 I know this is disappointing! It’s definitely working for a lot of customers, many many more than it previously was, but it’s not 100% for everyone yet.

We’re working closely with our data provider on this issue still and they’re in close contact with U.S. Bank. Generally, when a new site is enabled for open banking there are some issues initially. The institution will collect the issues/feedback and push changes in a batch within the first couple weeks. We’re still awaiting that initial patch to come out but expect it to be weeks, not months in this case.

Thanks for your continued patience.

Tiller announced that U.S. Bank transactions were again working. I followed the instructions, but my U.S. Bank transactions do not download to Tiller.

I really like the Tiller concept, but for almost a year, it has not been reliable. When will U.S. Bank be reliably downloading?

@chrisseubert please see my last reply above :point_up:

Is there any update on this? To help debug, here is what happens to me…

From the Tiller Console, I go to my US Bank account and chose “Edit Credentials”, which brings up…

I choose “Continue”, which takes me to US Bank Logon. I log into my US Bank Account, which tales me to…

I choose “Authorize”…

I choose the accounts I want to link (I have chosen some and all and the results are the same) and hit “Submit and Close”, which then gives me this encouraging screen…

This gets done and I’m back to this in the Tiller Console…

So optimistically, I hit “Refresh”, which takes me back to…

which then returns…

The balances it shows are correct, which looks promising. I hit “Save and Close”, but still, nothing’s been refreshed…

Not only does it say “unknown refresh date”, but there are no new transactions or balances loaded into my Tiller sheet.

Please work to fix this. It’s now been 8 months since the US Bank connection has not worked.

Hi @Cowboy13 - thanks for these details. We are reaching out to our data provider frequently to check in on the status of the fix.

What’s the latest update? Do you know if someone is actually working to fix this?

Yes, our data provider is 100% working on this issue. We’ve had some customers reporting it’s working for them again, that were experiencing issues after this open banking connection went live. Can you try it again?

Wow, it just worked for me; first time since mid January.

Hopefully it stays on line this time!

Thank you.


Glad to hear it! Hopefully it’s working for others as well.