Amazon - Stuck Analyzing My CSV File - Is It Me?

The CSV importer for Amazon has been working really well for me lately until today. It’s been “analyzing line items history” now for 15 minutes and the CSV has only 1 line item.

I have two - one big and one small. I tried both. Same. I rebooted spreadsheet. Same. Is it me or is the tool having a bad day?

I’m having the same issue. Tried two different computers with no luck.

Thank you! Whew. It’s a relief to know it’s not just me.

Help, @randy ?

I can reproduce the issue, @susandennis & @wyliej30. When I run the workflow with the Console open I see this error: SyntaxError: Unexpected end of file.

But, when I open the file— for both Item and Refund reports— I see the header row and then a “No data found for this time period” message.

Order Date,Order ID,Title,Category,ASIN/ISBN,UNSPSC Code,Website,Release Date,Condition,Seller,Seller Credentials,List Price Per Unit,Purchase Price Per Unit,Quantity,Payment Instrument Type,Purchase Order Number,PO Line Number,Ordering Customer Email,Shipment Date,Shipping Address Name,Shipping Address Street 1,Shipping Address Street 2,Shipping Address City,Shipping Address State,Shipping Address Zip,Order Status,Carrier Name & Tracking Number,Item Subtotal,Item Subtotal Tax,Item Total,Tax Exemption Applied,Tax Exemption Type,Exemption Opt-Out,Buyer Name,Currency,Group Name
No data found for this time period

Is this what your CSV looks like too? Maybe Amazon’s CSV generator is down currently?


Nope. I did check that (whew). The files I’ve tried are fully populated.

That looks right, @susandennis. I haven’t downloaded one in a few months and when I try to fetch one today they are all empty (and we have definitely purchased from Amazon in the past several months). No idea what is up.

Unfortunately, it is tough for me to debug without a file that is not parsing properly.

If you try to download an Items report right now, does it include transactions?

yep. just ran the same request again and got “No data found for this time period”


i’ll keep trying and let you know when i get good data. oh amazon, why can’t you play nice???

OOOOPS I think maybe I was wrong. I think the file with all the data was an old one.

I just ran it and it finished analyzing and then said ‘no new items’ which is exactly what I expect because the data in the CSV is what is reflected in my transactions.

And the CSV used when I first hit the problem was also empty.

So sorry. I need to do some file clean up!!

Bottom line, Amazon’s like the total cause of the problem… Again.

Thanks for trying again, @susandennis.

I’m amused that the code I wrote quickly and a long time ago continues to not be the problem.

1 Like

I just ran a report for items purchased - got a loaded sheet and the CSV tool worked fine.

I also ran a report for refunds - I know there were two in the timeframe - and got an empty report back.

So… Amazon fixes but maybe not totally. I think I’m going to start doing this amazon reconciling by hand. It probably wouldn’t hurt to have more focus on my overspending anyway :slight_smile:

Thanks for letting me know, @susandennis. I just caught up on my Items report but, like you, my Refunds came up empty after 8 months which is not right. Hopefully they’ll fix that too.