Cannot Upgrade Business Dashboard Using Tiller Money Labs

I am attempting to upgrade my Business Dashboard sheet from 1.10 to 2.05. I select the upgrade sheet prompt (I’ve tried both overwrite existing and archive options) and it looks like it updates. Then I immediately get the prompt that it needs upgrading again. Not sure what I’m doing wrong.

Screen Shot 2021-07-03 at 08.57.57

That is odd.

  • Is it possible that you have two versions of the template in your spreadsheet (perhaps an old one that is hidden)?
  • Or maybe the Tiller Money Labs add-on is having trouble writing the version metadata into the sheet?


There is no harm in deleting the current one (version 1.10) and then adding version 2.05 using the Add Solution workflow. (If you delete the one you have tried updating and the add-on still thinks the template is installed, that is a good indication that there is a hidden copy in your spreadsheet.)

Yep, I had a hidden version that, for some reason, I manually renamed “Dashboard”. Deleted it and upgrade went smoothly. Thank you!

It can be a little confusing because the templates contain embedded metadata for identification and version control. A hidden, renamed, or archived template may look different to you but to the Tiller Money Labs Add-on the versions may look identical.