Keep getting error now: "The state token is invalid or has expired. Please try again."

I searched and the last mention of this was last year. I can’t even use the damn thing now because every day this week I just get “The state token is invalid or has expired. Please try again.” Right when I try to log in from the sidebar. Nothing else has changed except this new error.

EDIT: if I keep trying it eventually comes up. sigh.

I keep telling myself it’s inexpensive, but it’s still a piece of software we are PAYING for.

@DDXdesign Are you using Google Sheets or MS Excel?

@Clint.C Google Sheets, sorry

What OS and browser are you using? I would assume Windows and Chrome but we have some Mac users too.

Have you already tried clearing the browser cache, rebooting your computer and router?

I’m ironically on MS Edge (built on chrome), but on a Mac.

I haven’t tried any of those things, but if I keep trying and it eventually works without doing those things, then those things are not likely to be the culprit.

Will you got me stumped.

I’m glad to hear it eventually works.

All I can suggests is a few other things I would try to narrow down the cause.

Maybe someone else here has the answer!