NEW Bug on adding accounts from the same institution AND same 4 last digits of Account #

Wondering if anyone else has recently run into this issue. I know it to be new, as I long successfully had two Amex cards that shared the same last 4 digits of account number. Today, I went to add a third which coincidentally shares the same last 4 digits, and here’s my frustrating experience so far:

To make it easier, I’ll refer to the accounts as:

  1. Tiller conflated two of those accounts (Old-A and New-C)
  2. I then deleted the conflated account, and tried re-adding the new one
  3. Same conflation now happened between the new account and the remaining old one. (Old-B and New-C)
  4. Deleted the second conflated account.
  5. Re-added the NEW account (New-C)
  6. Tried re-adding one of the two original ones (Old-A), and the same conflation happens again.
  7. Deleted it again, now leaving me with none of the 3 accounts I need.

Has this happened to anyone else and how have you mitigated? I’ve opened a support ticket and am hoping it can be solved soon.


We’re fielding this via the official support channel at