Transaction Tab Frozen

Have been using Tiller for a few years now and love it. Today, for the first time ever, my transactions tab seems to be frozen. Other tabs work fine, but transactions is frozen. I can get to it but can’t click on the category column to fill in categories. Any thoughts on how to troubleshoot? Thanks!

I’m curious what browser you’re using? I’ve seen a few reports of spreadsheets being frozen when people are using Safari. I tested it myself and it was frozen for a very long time, and I found some Reddit threads about some Safari + gSuite issues.

We do recommend Chrome.

I tried Safari and Chrome on multiple computers, iPads, etc. Same exact situation on all of them. Has to be an issue with Sheets.

In the years I’ve had Tiller this hasn’t happened once, ever.


Is the Transactions sheet still being updated by Tiller when you click the Fill Sheets button? The only other thought, I was wondering if you might have accidentally protected your sheet? If you click on the “Transactions” tab, and then click on the down arrow of that tab, there is a “Protect sheet” check on the sheet protections and see if the whole sheet is now protected?

Or maybe the entire sheet is frozen from the view menu, usually just the first row but maybe this got changed to at least the entire view from your screen by chance?

I believe it’s view then freeze option that you may need to look for?

I had this issue today with Safari but the transactions loaded correctly when I downloaded Chrome and pulled up my sheet in it. My issue was exactly the same in Safari - all the tabs worked fine, but if I clicked into transactions, the whole sheet froze and none of the transactions displayed. I also had the little blue bar at the top right showing sheets was still trying to load data.

Same issue here. Worked fine in safari for the last few months but today it’s totally frozen - after clicking ‘fill sheets’. Works fine in Firefox, etc.

Continuing to have this issue. Using Safari, Chrome, Firefox. On both computer and iPad. Would be great if a Tiller rep chimed in on this. It’s rendered Tiller mostly useless, and I just got charged for the year two days ago!

Anybody have an idea for a fox other than trying different browsers or different devices?

@james3332 I would suggest opening a support issue via chat to get help from support. It can be found in the lower right of your screen while logged into tiller.

1 Like

I’ve had the same problem for about a week now. If you leave the browser on the transactions tab for ~10-15 minutes it’ll eventually start working. My guess is something on Googles side.

Timing sounds right. Must be a google issue. Hope they fix it. Thx.

Here’s an Apple discussion thread with more context: Safari users are currently experiencing an issue with Google Sheets