US Bank -- Bank Feed Not Updating


I very much want to continue using Tiller; but it still does not connect to US Bank for me. I waited for months for the US Bank-Tiller connection to get fixed. US Bank is the fifth largest commercial bank in the U.S., and the fact that Tiller users (at least some of them) cannot reliably download their bank account transactions is something that I think Tiller needs to PROACTIVELY address. My credit card transactions routinely download to Tiller, even my USBank credit card. But, no transactions from my five other USBank accounts download to the Tiller Transactions tab as they should.

You have sent me standard Tiller instructions for connecting to USBank, and I have followed them carefully. But, they don’t work. In following your instructions, I encountered problems. Let me give you some examples; below, I describe a couple of the problems.

I got to the point where I was presented a screen that wanted three pieces of information:

  1. Organization Short Name

  2. User ID and

  3. Password

I know the ID and Password, but I don’t know what is an “Organization Short Name.” I tried USBank (and variations), and that’s not it. I tried the short name I gave one of my accounts “Main Account” (and variations) and that didn’t work. Your instructions don’t cover “Organization Short Name;” so, I need some help on that one.

I also logged into my USBANK account (on computer rather then my iPhone app) and went into the Account/Control/Manage Third-party Access screen for my bank accounts. The screen that pertains to Tiller looks like this:

As you can see above, there is a USBank, Envestnet/Yodlee/Tiller connection. And as you can see below, I have given Tiller access to all accounts and documents. By the way, I didn’t notice “Envestnet” being mentioned. Anyway, it seems that my USBank online accounts are connected to Tiller, at least from the USBank Third-party access standpoint.

Here is some information on the Tiller side. When I open my linked Tiller sheet and access the Tiller sidebar (shown below) and open “Connected Accounts” (I won’t display that for security reasons), but all of the accounts APPEAR to be accessed and that none of them need “attention” In actuality, only the transactions from my USBank Visa account are downloaded. Nothing is downloaded from the other five accounts, even though they would APPEAR to be properly connected.

Heather, I am sure that you can see that I have put a lot of effort into this. When I said “PROACTIVELY address” above, I mean that somebody needs to carefully look at my situation and give me some instructions that work. I highly recommend that somebody give me a call and walk me through the USBank connection proces****s. In talking to me, I believe that your support staff could learn how to improve your written instructions. I find them rather opaque, and I think that I could give some suggestions to your support people on how to improve your written instructions that would make them clearer, more specific and more helpful to your users.

Bottom Line: Please have someone email/text me [PII deleted by Tiller staff]

By the way, Tiller is very important for managing my budget, and after months of inferior service, this issue is becoming critical for me. Please help me.

Chris Seubert

HI @chrisseubert - we are working closely with our data provider still to resolve the U.S. Bank issues some customers are still experiencing. This is still a widespread issue and a 1:1 reach out won’t solve it, though I wish it would!

Not sure if it will help anyone but I just checked today and my US Bank account refreshed and all my transactions were pulled in.

Crossing fingers that it keeps working.

1 Like