Tiller increasingly irrelevant with so much of my data missing

A few days ago I opened ticket: #3168: Bank Feed Issue the gist of which is that after two successful months I am no longer receiving downloads from the bank that I use for all my household infrastructure payments (mortgage, electricity, gas, etc). Now it has been 11 days since it connected. My best guess is it is a mfa issue. The bank requires a voice phone call to get a code. In the ticket it was suggested that I try connecting with my.tiller on an incognito connection, which I did without success.
And that was it. No more communication. It has been four days now of silence.

Without downloaded data, my spreadsheet is becoming increasingly skewed as transactions occur and nothing is updated in Tiller.

The questions I have are:
1 - What happens when tickets are ignored after the initial failed interaction?
2 - What kind of recourse is there if this can not be fixed? Changing banks because one of them doesn’t work with Tiller seems a bit much to me.

I really like the results of Tiller but the one thing that makes or breaks the process is connections and automatic downloads. Without that it is not so much more than I was doing manually before.


I am having a similar issue as well. Signed up in December and had no issues until a few weeks ago. I have tried everything they have suggested. My bank balances look correct, so I am not certain it is a bank connection issue? Regardless, it has been about 10 days now since logging the issue and 2 days since I have had a response to the last attempt. This is my main account that I use so if this can’t be fixed, then I am not sure this will be the tool for me to use. Which is really disappointing. Searching the Tiller Community it seems there are other having similar issues. Hopefully they can get it sorted.


Looking a bit on Reddit I did discover that the aggregator that feeds Tiller, Yodlee, is a company that feeds other similar finance apps. (Yodlee - Wikipedia) They are a pretty big organization but from the people on Reddit have connection issues that effect a lot of their customers, such as Tiller. They have a bunch of competitors but all have similar problems. There are so many financial institutions many of which have unique connection set ups. The one I’m having an issue with is a fairly small Texas credit union. Their multi factor is a phone call. If I have to fix my connection I check the box to call (text is not an option) and I get a computer calling me with the six digit mfa. It is really behind the times and that is the problem, I’m sure, that Yodlee is having. I do not remember how it was connected in the first place. It worked for two months so I got it fixed somehow in the initial set up. Very annoying.

I don’t have a lot of transactions with this account. It is for my mortgage payment and my utilities. I keep it so I’ve got a local bank I can walk into and deposit cash. If I could make it work manually and have it populate through the tabs I’d be able to live with that but I tried to do that and it didn’t populate.

Frustrating. My comment to Tiller was that I’d be happy if they charged more and provided more immediate support.

Seems strange that your balance is correct if you are getting a logging issue. Are your transactions populating too?

Makes sense with smaller banks. Mine happens to be one of the largest in Colorado. I have never really had an issue with it on other platforms. I trigger the refresh, it acts like it is updating. I get no error message at all. My balances pop up and are updated. I hit save and close. And then the tiller portal shows that it is not refreshed. And no transactions loaf to my workbook. So it is sort of odd. I feel like it is connecting (enough to get an updated balance) but transaction load is timing out or not working. I have tried incognito browser, resetting credentials (even my security questions) to see if I can trigger an error of some sort. I got an update from the service team today that they have submitted it to Yodlee but it can be up to 6 weeks. Which is just not great service. I get they are at the mercy of the third party provider and I agree I would pay more if it meant a better experience. I am about to see how just manually downloading transactions might work. I do really like the format of the tool. So it might be an ok solution until they get it fixed. But I am not sure long term that is the answer.

Yeah, different issue. It sounds more like a Tiller issue but I don’t know much about their end. I think the six week answer is a standard cut/paste response that support sends.

Yodlee appears to be the big player in the aggregate world, though, so dealing with them might be difficult.

Unfortunately, I don’t think the size of the bank has much to do with it. It’s just as likely for a large bank to give aggregators fits as it is for a small bank. As I wrote about at some length here, there’s a lot that goes into getting your data from the financial institution to your Tiller sheet. Sort of an obstacle course that your data has to successfully get through, and the obstacles are often constructed by the banks themselves.

For what it’s worth, I was just reading a long thread on another forum about frustrations with bank connection issues on one of Tiller’s competitors that uses a different aggregator than Yodlee. These issues are kind of endemic to this whole space. The only way to avoid them might be to consciously choose to put your money at institutions that have already made the switch to Open Banking standards that make data more easily accessible.

@rachelfhall Are you using FirstBank?

I’m having similar issues when my primary checking with FirstBank only updating balances and not downloading transactions after 2/29, but my other accounts there (with much fewer transactions) are coming through fine. I opened a ticket on this yesterday. But my Portal does say it was refreshed (though it does take a while when running through the portal)

Yes! It is FirstBank and I would say my issue started about that time as well. I have a few accounts there but mine all seem to be impacted. If I hear anything back I will let you know.

Update: I tried refreshing on the Tiller Console this morning again and it worked!!! I now have transactions pulling back into my workbook again. So it seems that once they got it submitted to Yodle, that was a fairly quick turn around on the Yodle side to fix. Ron, I hope that perhaps your issue with FirstBank is fixed as well? Happy days.

That’s a great writeup and I’m still figuring it out.

Unfortunately it is kind of like fully understanding why my car crashed. Good to know but still.

I’ve considered switching banks and it is a possibility. I’m not married to this one but I do need a local bank to counterbalance USAA, my primary. I need a lobby where I can walk in and deposit cash. Hardly ever happens but I feel pretty strongly about having something local.

I might review the choices and see if I can find one I like that has Open Banking Standards. Thanks for the tip.

While looking for a bank that supports open banking and does not require me to keep $1k in a nearly zero interest checking account I found this:

The CFPB is working to convince ALL banks to allow customers to share their data with third parties. What we’re talking about.

Seems like a good idea that would solve Yodlee’s problem and Tillers so I’m sure there is a lot of resistance somewhere.

I am having a hard time finding a bank that doesn’t force me to put money in without a decent interest rate while maintaining Open Standards.

I’ll keep looking. Something has to bubble up.

Yeah, there’s a group of folks in Congress who have taken an interest in Open Banking standards. That’s where the CFPB push is coming from. The problem is that banks have little incentive to get on board. It costs them money to make the change, and all they will get in return is loss of control over their customers’ data, which is one of their most valuable assets.

Fwiw, I believe Ally uses some form of Open Banking. Their interest rates are good, and my connection through Tiller is fast and has been rock solid. Only downside for you is that it won’t have a branch to visit.

1 Like

@rachelfhall Glad yours is working, mine still is not but hopefully it’s a matter of timing and it also starts working in the next day or so. Thanks for the update

Well I spoke a bit too soon. My console now shows it is updated. I did get transactions loaded up to March 7. But now I think I have a similar issue to you. I have a savings account that seems to be loading fine. Other accounts have gaps. So might be closer but still some issues.

1 Like

You nailed the problem. I use USAA and have since they first opened the bank. It works for me except for the brick and mortar issue. Ally is enticing but no help with the bricks.

Is there a Tiller list of banks that work? I do a search for ‘open standards banks near me’ and get a bunch of banks I doubt fit the description. I’d ask the banks but doubt they would give me a straight answer if they even knew about the question.

I think I’m stuck with a b/m bank that requires minimum deposit and very low interest or suck it up and manually enter in Tiller.

Tiller’s sheet of supported institutions has a column for open banking. Not sure how regularly that’s updated. (For example, Ally is a no on that sheet, but I’m pretty sure they’ve adopted the standards.)

I apologize for being lazy. Should have looked for that before asking.

But, yeah, not quite right. It has my credit union, the one that isn’t working, on the list. UHCU.

Still, it is interesting.

@bill.schubert your bank is supported meaning it’s available in search to try and connect (it was working at one point, remember?) but the connection is just broken now. But it is not listed as being an open banking site.

@dmetiller the list is updated quarterly. Ally has not yet implemented an open banking connection with Yodlee.

Interesting, @heather. It behaves like an open banking institution—quick, reliable connection—and Ally talks the talk about open banking in various places.

When I search to add it, it’s still showing entering un/pw directly into Yodlee’s UI (vs navigating to Ally bank directly to connect). That’s the big difference. They may have it enabled for other aggregators.

1 Like